On Mar 7, 2006, at 9:26 PM, Christos Zoulas wrote:
And they are already causing conflicts [BITS is defined in zlib]. Maybe prefix all the generic names with BIT_? BIT -> BIT_GET_MASK BITS -> BIT_GET_MASK_BETWEEN
ISSET -> BIT_ISSET CLR -> BIT_CLEAR SET -> BIT_SET
These three are unlike the others... ISSET(), CLR(), and SET() operate on masks, whereas the other ones operate on bit positions. So, you would either have to change the usage of these three macros to match the bit position semantics (otherwise confusion would flourish), or these should be called BITMASK_ISSET(), BITMASK_CLR(), BITMASK_SET() (so much for saving the extra typing!).
-- thorpej