Subject: Re: CVS commit: src/sys
To: None <source-changes@netbsd.org>
From: Christos Zoulas <christos@astron.com>
List: source-changes
Date: 03/08/2006 05:26:30
In article <1141795070.996033.1451.nullmailer@yamt.dyndns.org>,
YAMAMOTO Takashi <yamt@mwd.biglobe.ne.jp> wrote:
>> A brief description of each macro is below.
>>
>> BIT(n): Return a bitmask with bit m set, where the least
>> significant bit is bit 0.
>>
>> BITS(m, n): Return a bitmask with bits m through n, inclusive,
>> set. It does not matter whether m>n or m<=n.
>> The least significant bit is bit 0.
>
>seem like too generic names to me.
>
>YAMAMOTO Takashi
And they are already causing conflicts [BITS is defined in zlib].
Maybe prefix all the generic names with BIT_?
BIT -> BIT_GET_MASK
BITS -> BIT_GET_MASK_BETWEEN
ISSET -> BIT_ISSET
CLR -> BIT_CLEAR
SET -> BIT_SET
etc.
christos